Feedback

Coordinator
Oct 5, 2011 at 5:32 PM

Please use this discussion to provide any feedback on the toolkit that you may have

Oct 6, 2011 at 9:16 AM

There is a bug in Visual Studio 11 Detection Script (CheckVS11OrExpress.ps1). Sometimes the script cannot detect OS architecture properly so that it could not detect Visual Studio 11.

I created a fix:

function HasVS11()
{
    $os = Get-WmiObject Win32_OperatingSystem; #my fix here
 if ($os.OSArchitecture -like "64*")

function HasVS11Express()
{
    $os = Get-WmiObject Win32_OperatingSystem; #and here
 if ($os.OSArchitecture -like "64*") 

 

Cheers

Coordinator
Oct 7, 2011 at 3:41 AM

Hi thanks for the heads up mwalanus.

Kind Regards,

Nick Harris


From: mwalanus [notifications@codeplex.com]
Sent: Thursday, October 06, 2011 2:16 AM
To: Nick Harris
Subject: Re: Feedback [WATWindows8:274883]

From: mwalanus

There is a bug in Visual Studio 11 Detection Script (CheckVS11OrExpress.ps1). Sometimes the script cannot detect OS architecture properly so that it could not detect Visual Studio 11.

I created a fix:

function HasVS11()
{
$os = Get-WmiObject Win32_OperatingSystem; #my fix here
if ($os.OSArchitecture -like "64*")

function HasVS11Express()
{
$os = Get-WmiObject Win32_OperatingSystem; #and here
if ($os.OSArchitecture -like "64*")

Cheers

Nov 2, 2011 at 11:55 PM

When uploaded to Azure, the https communications between the client and the azure web host seems to work only if the web role is set to production.   If it is VIP to staging and one uses the staging URL host name, the URI connection is not made (error).  I assume the client is thwarted by a non-working https protocol.

Is there guidance in the readme not to use staging, or to swap to http protocols?  Does this sound like the possible problem, or should the same code operating in production role and in the staging role work the same as long as the hostname is changed to the Azure-based register service?

 

Nov 15, 2011 at 2:40 PM

Hello,

I have tried installing this toolkit under both Win 7 and Win 8 with no luck. I receive the following error message when trying to use the project template:

A problem was encountered creating the sub-project 'Windows8CloudApp1.Web'. Value does not fall within the expected range.

Any help would be greatly appreciated.

Thank you,

Brian

 

 

 

Coordinator
Nov 15, 2011 at 3:34 PM

Hi Brian,

Please launch VS2010 from the link the toolkit placed on your desktop VisualStudio2010WindowsAzure.cmd. This cmd sets a variable required for the Windows Azure bits on Windows Developer Preview.

More details in Step 1 - http://watwindows8.codeplex.com/wikipage?title=Creating%20a%20New%20Windows%208%20Cloud%20Application&referringTitle=Documentation

Kind Regards,

Nick Harris

From: bkbro [email removed]
Sent: Tuesday, November 15, 2011 7:40 AM
To: Nick Harris
Subject: Re: Feedback [WATWindows8:274883]

From: bkbro

Hello,

I have tried installing this toolkit under both Win 7 and Win 8 with no luck. I receive the following error message when trying to use the project template:

A problem was encountered creating the sub-project 'Windows8CloudApp1.Web'. Value does not fall within the expected range.

Any help would be greatly appreciated.

Thank you,

Brian

Dec 7, 2011 at 8:44 PM

Hi,

I downloaded the Push Notification sample on a Windows 8 box (build 8102) and it works only when the private server URL is https://127.0.0.1/WNSNotificationService/ but if I change it to https://localhost/WNSNotificationService/ or even https://hostipaddress/WNSNotificationService/ the Metro app fails to send the Channel URI to the server. I looked at the status code and it seems to be set to 0 and statusText is also empty.

I also want to be able to install the Metro App on a different machine and try to connect to the same server. But that also fails.

I've already tried changing the endpoint to use http and also removing the Sslcertificate to "Not Set" but none of this seem to work. If I do this I can't even seem to launch the Web service.

Can you please let me know what changes I need to do to make this work with a different URL and from a different machine.

Thanks,

Sandeep

Dec 14, 2011 at 5:18 PM

After watching Nick's BUILD video, I downloaded and intalled the prereqs and toolkit. I created an app using the Win8 cloud template, I successfully launched the web app and accessed the web portal at https://127.0.0.1/. I successfully launched the Metro app in VS11. But when I hit the 'reopen channel' button, I get the message "could not create the channel (error nbr 3002)". After a quick investigation on the client I can see the channel gets created OK but the registerChannel call returns a "405 - HTTP verb used to access this page is not allowed" (confirmed in Fiddler).  I looked throughout the cloud project but couldn't find the definition of the PUT operation - only POST operations defined in the PushNotificationController.

Any suggestions ?

Coordinator
Dec 14, 2011 at 5:24 PM
Edited Dec 14, 2011 at 7:35 PM

Hi ykhammal,

 

Are you using the latest drop of the toolkit? i.e the version deployed to codeplex yesterday?

 

Kind Regards,

Nick Harris | Technical Evangelist, Windows Azure 

 

 

 

Blog: http://www.nickharris.net

Twitter: http://twitter.com/cloudnick

 

From: ykhammal [email removed]
Sent: Wednesday, December 14, 2011 10:18 AM
To: Nick Harris
Subject: Re: Feedback [WATWindows8:274883]

 

From: ykhammal

After watching Nick's BUILD video, I downloaded and intalled the prereqs and toolkit. I created an app using the Win8 cloud template, I successfully launched the web app and accessed the web portal at https://127.0.0.1/. I successfully launched the Metro app in VS11. But when I hit the 'reopen channel' button, I get the message "could not create the channel (error nbr 3002)". After a quick investigation on the client I can see the channel gets created OK but the registerChannel call returns a "405 - HTTP verb used to access this page is not allowed" (confirmed in Fiddler). I looked throughout the cloud project but couldn't find the definition of the PUT operation - only POST operations defined in the PushNotificationController.

Any suggestions ?

Coordinator
Dec 14, 2011 at 7:33 PM

Hi Sandeep,

The issue you are experiencing here is that the self signed certificate is for 127.0.0.1 and not localhost or hostipaddress and the trust relationship has only been configured on the client for the self signed certificate for 127.0.0.1 this is not much of an issue when moving to production as your certificate will come from a trusted root cert authority.  To resolve for your dev environment you can do any of the following:

  • use a signed certificate
  • or, establish a trust relationship for your new self signed certs used by your service for "localhost" or "hostipaddress" in your client apps package.appxmanifest declarations tab by updating the certificate Declaration to replace the current declaration for 127.0.0.1
  • remove https support - not recommended.  if this is the route you would like to take let me know and i will provide more details on private im.

Kind Regards,

Nick Harris

Dec 15, 2011 at 12:08 AM
Edited Dec 15, 2011 at 9:42 AM

Hi Nick,

Yes, I downloaded and installed WATWindows.Setup.20111213.1_CTP.exe today

Apparently the implementation in this version is quite different from the one you showed at BUILD. For example, in the previous version I could see clearly which part of the server code was invoked by the client to register the channel Uri, whereas I haven't yet figured it out in this new version. Can you help me trace where that PUT operation (which is apparently not allowed when running the code out of the box) is defined ?

Thanks
Yacine 

EDIT :
Tried replacing the request method in the client from PUT to POST, I get an 'endpoint not found', which makes sense if a PUT is expected. Tried a GET, a response is correctly returned with an empty array obviously. With a PUT the endpoint is apparently found but not allowed, authentication issue ? perhaps I forgot to configure something

By the way, my win8 dev prev system keeps crashing ever since I installed and started running the toolkit

Coordinator
Dec 15, 2011 at 3:30 PM
Hi ykhammel are you using the client app generated by the project or your own? If using your own ensure you have client, client server and home/network checked in the appmanifest

Sent from my Windows Phone

From: ykhammal
Sent: 14/12/2011 17:08
To: Nick Harris
Subject: Re: Feedback [WATWindows8:274883]

From: ykhammal

Hi Nick,

Yes, I downloaded and installed WATWindows.Setup.20111213.1_CTP.exe today

Apparently the implementation in this version is quite different from the one you showed at BUILD. For example, in the previous version I could see clearly which part of the server code was invoked by the client to register the channel Uri, whereas I haven't yet figured it out in this new version. Can you help me trace where that PUT operation (which is apparently not allowed when running the code out of the box) is defined ?

Thanks!
Yacine

Dec 15, 2011 at 4:03 PM

I'm using the app generated by the template. All these capabilities are enabled. Tried removing the authorization attribute on the server, no difference, the invocation returns 405 - HTTP verb used to access this page is not allowed

Coordinator
Dec 15, 2011 at 4:40 PM

Are you sitting behind a proxy ?

From: ykhammal [email removed]
Sent: Thursday, December 15, 2011 9:04 AM
To: Nick Harris
Subject: Re: Feedback [WATWindows8:274883]

From: ykhammal

I'm using the app generated by the template. All these capabilities are enabled. Tried removing the authorization attribute on the server, no difference, the invocation returns 405 - HTTP verb used to access this page is not allowed

Dec 15, 2011 at 4:52 PM

No I'm not. The channel gets created OK, so  the communication with WNS works fine. I can access the "endpoints" URI using a GET.  Turned off Fiddler to make sure nothing interferes, but no difference. 

Coordinator
Dec 15, 2011 at 5:30 PM

Hi ykhammal,

Could you zip and send your solution to watwindows8@microsoft.com I will confirm here that it is working in my environment and we can then resume this thread from there from my internal email.

Further could you check:

· Your event log if there are any related errors logged

· Your firewall is turned On and there is an Inbound rule named Windows Azure Toolkit for Windows 8 local

· The 127.0.0.1 certificate is in your / Computer/Trusted Root Authorities – check that it has the thumbprint starting with f8 and ending with a3 i.e same as what is in the solution

Kind Regards,

Nick

From: ykhammal [email removed]
Sent: Thursday, December 15, 2011 9:53 AM
To: Nick Harris
Subject: Re: Feedback [WATWindows8:274883]

From: ykhammal

No I'm not. The channel gets created OK, so the communication with WNS works fine. I can access the "endpoints" URI using a GET. Turned off Fiddler to make sure nothing interferes, but no difference.

Dec 16, 2011 at 12:21 PM

 Hi Nick,

I've uploaded the zipped solution to my sky drive, but again it's just the generated template files, no changes :
https://skydrive.live.com/redir.aspx?cid=72ad381d14accb2f&resid=72AD381D14ACCB2F!351&parid=72AD381D14ACCB2F!139&authkey=!AANTTqBEuOjgoQE

I haven't found any related error in the event log.
My firewall does have the Windows Azure Toolkit inbound rule.
I checked the certificate store, it does contain the 127.0.0.1 certificate with the matching thumbprint.

Note that the cloud app starts fine in the azure emulators, the portal page comes up right away in the browser - without the security certificate warning page.
Again the "endpoints" endpoint exists but returns a "405 - Http verb used to access this page is not allowed".

Thanks!

Yacine Khammal

Dec 16, 2011 at 12:30 PM

Additional info : tried launching the Margie's Travel sample, the browser displayed the following config error message :

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: ID1024: The configuration property value is not valid.
Property name: 'serviceCertificate'
Error: 'ID1039: The certificate's private key could not be accessed. Ensure the access control list (ACL) on the certificate's private key grants access to the application pool user.
Thumbprint: 'F8ACE24A36F93B006BFAF495F6C14FB827AC61A3''

Source Error:

Line 90:   </system.serviceModel>
Line 91:   <microsoft.identityModel>
Line 92:     <service saveBootstrapTokens="true">
Line 93:       <audienceUris>
Line 94:         <add value="https://127.0.0.1/" />


Source File: C:\WindowsAzure\WATWindows\Samples\MargiesTravel\MargiesTravel.Web\web.config Line: 92

 

Additional info found in VS :

<!--

[CryptographicException]: Keyset does not exist

at System.Security.Cryptography.Utils.CreateProvHandle(CspParameters parameters, Boolean randomKeyContainer)

at System.Security.Cryptography.Utils.GetKeyPairHelper(CspAlgorithmType keyType, CspParameters parameters, Boolean randomKeyContainer, Int32 dwKeySize, SafeProvHandle& safeProvHandle, SafeKeyHandle& safeKeyHandle)

at System.Security.Cryptography.RSACryptoServiceProvider.GetKeyPair()

at System.Security.Cryptography.X509Certificates.X509Certificate2.get_PrivateKey()

at Microsoft.IdentityModel.X509Util.EnsureAndGetPrivateRSAKey(X509Certificate2 certificate)

[ArgumentException]: ID1039: The certificate&#39;s private key could not be accessed. Ensure the access control list (ACL) on the certificate&#39;s private key grants access to the application pool user.

Thumbprint: &#39;F8ACE24A36F93B006BFAF495F6C14FB827AC61A3&#39;

at Microsoft.IdentityModel.X509Util.EnsureAndGetPrivateRSAKey(X509Certificate2 certificate)

at Microsoft.IdentityModel.Configuration.ServiceConfiguration.GetServiceCertificate(ServiceElement element)

[ConfigurationErrorsException]: ID1024: The configuration property value is not valid.

Property name: &#39;serviceCertificate&#39;

Error: &#39;ID1039: The certificate&#39;s private key could not be accessed. Ensure the access control list (ACL) on the certificate&#39;s private key grants access to the application pool user.

Thumbprint: &#39;F8ACE24A36F93B006BFAF495F6C14FB827AC61A3&#39;&#39; (C:\WindowsAzure\WATWindows\Samples\MargiesTravel\MargiesTravel.Web\web.config line 92)

at Microsoft.IdentityModel.Configuration.ServiceConfiguration.GetServiceCertificate(ServiceElement element)

at Microsoft.IdentityModel.Configuration.ServiceConfiguration.LoadConfiguration(ServiceElement element)

at Microsoft.IdentityModel.Configuration.ServiceConfiguration..ctor()

at Microsoft.IdentityModel.Web.FederatedAuthentication.get_ServiceConfiguration()

at Microsoft.IdentityModel.Web.HttpModuleBase.Init(HttpApplication context)

at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)

at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)

at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)

at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)

[HttpException]: ID1024: The configuration property value is not valid.

Property name: &#39;serviceCertificate&#39;

Error: &#39;ID1039: The certificate&#39;s private key could not be accessed. Ensure the access control list (ACL) on the certificate&#39;s private key grants access to the application pool user.

Thumbprint: &#39;F8ACE24A36F93B006BFAF495F6C14FB827AC61A3&#39;&#39; (C:\WindowsAzure\WATWindows\Samples\MargiesTravel\MargiesTravel.Web\web.config line 92)

at System.Web.HttpRuntime.FirstRequestInit(HttpContext context)

at System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context)

at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context)

-->