404 Error on Send

May 9, 2012 at 2:57 AM
Edited May 9, 2012 at 3:40 AM

I have the following code (pretty standard). When I call Send I always get "The remote server returned an error: (404) Not Found"

. I am using it just like the examples I have seen. What am I missing?

 

IAccessTokenProvider _tokenProvider = new WnsAccessTokenProvider("ms-app://s-1-15-...", "PR13MQmi..."

);   //Construct a toast notification for a given CchannelUrl

 var toast = new ToastNotification  

(_tokenProvider) ttps://db3.notify.windows.com/?token=AgUAAADcjhbhl19G7vxqAphDcx...

{

ChannelUrl = h

 

,

ToastType =

ToastType

.ToastImageAndText02,

Image =

"https://127.0.0.1/devstoreaccount1/tiles/WindowsAzureLogo.png"

 

new List<string> {"Sending notifications from a Windows Azure WebRole"

 

NotificationSendResult result = toast.Send();

 

 UPDATE: I noticed there was an update NuGet package (0.3) so I installed that hoping that was my issues. My code now looks like this:

 IAccessTokenProvider _tokenProvider = new WnsAccessTokenProvider("ms-app://s-1-15-2-3731121895...", "PR13M....");
           
            IToastText01 toast = ToastContentFactory.CreateToastText01();
            toast.TextBodyWrap.Text = "test it agian";
            var results = toast.Send(new Uri("https://db3.notify.windows.com/?token=AgUAAADc...."),_tokenProvider);

 

Sadly the results are still the same 404 error.

May 26, 2012 at 11:23 PM

Looks like no one is really monitoring this forum from MSFT. Solved the issue. My channel in my app was not persiting so it really did not exist.